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General Comments
Welcome to Pretty Good Solitaire!    This program started because I was unsatisfied with the solitaire 
programs out there.    There's some good ones, but usually they come only 1 or 2 games at a time, 
with no undo feature, and so on.    And so I started to write my own.

This collection of games contains some of my favorite solitaire games.    Every game has full undo 
and redo (except for when the deck is reshuffled).    I am continually writing more games, so keep 
watching where you found this game for more up to date versions with more games.

Acknowledgements
Thanks to Microsoft for Visual Basic 3.0, which allowed a humble programmer like myself to write 
games like this.    Thanks to Stephen Murphy for writing QCARD.DLL, the wonderful playing cards 
that this program uses.    Thanks to my beta testers: Michael Calligaro, Lorrita Morgan, Kevin 
McGillicuddy, Kevin Crowley and others.    And thanks to my primary tester, Diane.

Version History
Version 1.0 - released 7/19/95 - contained the original 5 games, FreeCell Towers, Baker's Dozen, 
Golf, Fourteen Out, and Yukon.

Version 1.1 - released 8/15/95 - bug fixes on FreeCell Towers, Baker's Dozen, and Yukon.    Five new
games- Busy Aces, 5 Piles, EastHaven, La Belle Lucie, and St. Helena.

Version 1.2 - released 9/25/95 - Five new games- Spiderette, Eagle Wing, Deuces, Perpetual Motion,
and Storehouse.



Notes about the AutoPlay feature
AutoPlay
AutoPlay is the feature that moves playable cards from the tableau to the foundations automatically.   
(Only those games with foundations have this feature, of course.)      This feature can be a great time 
and effort saver, and I highly recommend its use.

However, there are a couple of things about AutoPlay that you should be aware of.    First, in some 
games (such as FreeCell Towers, Yukon, etc)    it is not necessarily a good idea to automatically play 
every possible card to the foundations.    In these games, the best strategy is to keep the foundations
pile roughly even with each other (for example, don't play the clubs foundation pile up to 5 or 6 when 
the ace of hearts hasn't come out yet).    Because of this, the AutoPlay feature will NOT play a card to
the foundations if it determines that that card might be necessary for play on the tableau.    You can, 
of course, override this if you wish by playing the card to the foundations yourself.    But remember, if 
AutoPlay doesn't move a card that it could move, there's a reason.

Secondly, although in many games it is technically cheating, these games allow you to move a card 
from the foundations back to the tableau, if you wish.    However, if AutoPlay is turned on, the 
AutoPlay feature will promptly play the card back to the foundation!    Therefore, if you ever want to 
do this you will need to turn AutoPlay off.



Auto Play
By selecting Auto Play from the Options menu, any cards in the tableau or cells that can be legally 
moved to the foundation are automatically moved there.    This speeds up play.

Important Notes about the AutoPlay feature



Benefits of Registration
The registration price for this program is only $6.95!    That's less than 50 cents a game.    This 
program is shareware, and if you use it for longer than a 30 day evaluation period, you should 
register the program.

How to Register
If you do register this program, this is what you will get for your money:

· FREE upgrades to all future versions, if you have a Compuserve, America Online, or Prodigy 
account.    These upgrades will be sent by e-mail, so be sure to include your e-mail address on 
the registration form.    Sorry, at this low registration price there's no way I can send upgrades by 
snail mail.

· Immediately, a version of the program without the nag screen. (Also by e-mail)
· Technical support, via e-mail.
· The eternal gratitude of the author.



How to register
Pretty Good Solitaire is a program intended to provide simple and cheap games for Windows.    Many
more solitaire games are under development.

To register your copy of the Tom's Pretty Good Solitaire, print out the registration form and send 
$6.95.    This price registers all the games!    

Incidently, the shareware versions of these games are fully functional versions.    But since every 
program can be improved, watch for updated versions along with additional solitaire games.    
Suggestions for new features and games are always welcome.

Registration Form



Registration Form
Tom's Pretty Good Solitaire 1.2
(FreeCell Towers, Baker's Dozen, Golf, Fourteen Out,Yukon, Busy Aces, 5 Piles, EastHaven, La 
Belle Lucie, St. Helena, Spiderette, Eagle Wing, Deuces, Perpetual Motion, Storehouse)

Print out this form.    (To print, select Print from the File menu.)
Send this form along with a check for $6.95 to:
Thomas Warfield
1309 N Hershey Rd #8
Bloomington IL    61704

Name_________________________________

Address_______________________________

City__________________State_____Zip_____

E-Mail address__________________________

Where did you hear about Pretty Good Solitaire?

______________________________________

Suggestions:

______________________________________

______________________________________

______________________________________



About
Pretty Good Solitaire 1.2: FreeCell Towers, Baker's Dozen, Golf, Fourteen Out, Yukon, Busy Aces, 5 
Piles, EastHaven, La Belle Lucie, St. Helena, Spiderette, Eagle Wing, Deuces, Perpetual Motion, 
Storehouse.

© Copyright 1995 by Tom Warfield

Thomas Warfield
1309 N Hershey Rd #8
Bloomington IL    61704

Technical Support is available by e-mail to:    Tomstaaf1@aol.com (note the last character before the 
@ is a one) or on Compuserve: 75237,254.



FreeCell Towers
In FreeCell Towers, the entire deck is dealt into 8 piles of cards, called the Tableau.    Above the 
tableau are 4 cells (marked with X's), and 4 foundation piles (to the right of the cells).    The object of 
the game is to build up the foundation piles from ace to king, one for each suit.    The first cards that 
go on the foundation are the aces, then a two of the same suit can be placed on an ace, and so on.    
The game is won if all 52 cards are moved to the foundation piles.

The top card of any tableau pile can be moved to a foundation pile, if possible.    The top card of any 
tableau pile can also be moved to any cell.    Only one card is allowed at a time in a cell.    Cards in 
the cells can be moved to the foundation piles, if possible, or back to the tableau, if possible.

Only the top card of any tableau pile can be moved, unless there are enough empty cells or tableau 
piles that a group of cards could be moved individually.    In that case, the entire group can be moved 
at once as a shortcut.    Cards can be moved among the tableau piles according one of two rules: if 
the FreeCell rule is set, tableau piles are built down by alternating color; for example, a red 7 could 
be played on a black 8.    If the Seahaven Towers rule is set, tableau piles are built down in suit.    
That is, only a 7 of spades could be played on an 8 of spades.    Which rule is in force is set in the 
Options menu.

All settings are automatically saved each time you exit FreeCell Towers.    Once you have the 
settings you want, you won't need to ever change them again if you don't want to.    If you exit the 
program before finishing a game, the game is automatically saved and you can resume play when 
you run FreeCell Towers again.

New Game
Restart Game
Undo
Redo
Statistics
Rules
Card Backs
King Only
Auto Play



New Game
Selecting New Game from the Game menu will deal out a new deck.    In some programs (such as 
FreeCell Towers), the program will first ask if you want to resign your current game.    If yes, it will add
a loss to your statistics.



Restart Game
Selecting ReStart Game from the Game menu will start the current game over again from the 
beginning.    This will not affect your statistics in the programs that keep statistics.



Undo
Selecting Undo from the Options menu will undo the last move.    Moves can be undone back to the 
beginning of the game (of course, ReStart Game would be easier in this case).



Redo
Selecting Redo from the Options menu will replay any moves you have undone.    In case you 
change your mind.



Statistics
Selecting Statistics from the Options menu will show you your current statistics.    Depending on the 
game, It shows how many games you have won or lost, your winning percentage, and the average 
number of moves of your wins, or how many points you have.    You can clear your statistics back to 
zero at any time.



Rules
Selecting Rules from the Options menu allows you to select between the two move rules on the 
tableau: FreeCell rules, where the tableau builds down by alternate colors, and Seahaven Towers 
rules, where the tableau builds down by suit.    Obviously, Seahaven Towers rules are somewhat 
harder.



Card Backs
Selecting Card Backs from the Options menu allows you to select between 6 different card backs.    
Card Backs are only visible in the foundations before aces are placed there, or in games where 
some cards are face back.    In some games, the change of card back will not go into effect until a 
new game is started.



King Only
By selecting King Only from the Options menu, you can only fill an empty tableau pile with a King.    
With this not selected, any card can be placed in an empty tableau pile.



Bakers Dozen
In Baker's Dozen, the entire deck is dealt into 13 piles of 4 cards each.    The 4 kings are immediately
moved to the bottom of their piles.    The top card of each pile is available for play.

The 4 piles at the right of the screen are the foundation piles.    The foundation piles are built up in 
suit from ace to king.    The game is won when all 52 cards are    moved to the foundation piles.

The 13 tableau piles are built down regardless of suit.    For example, a 7 of hearts could be played 
on an 8 of diamonds.    Only one card at a time may be moved.    Any spaces left by removing an 
entire pile cannot be filled.

New Game
Restart Game
Undo
Redo
Statistics
Card Backs
Auto Play

Tips: Don't let one foundation get too far ahead of the others.    Watch for piles that contain a lower 
card of a suit below a higher card of the same suit.



Golf
Golf is a very simple game to play, but difficult to win.    Seven piles of 5 cards each are dealt face up,
forming the tableau.    One more card is dealt face up to become the waste pile.    The rest of the 
cards are dealt face down in the stock pile.

Only the top card of each pile is available.    To play, build in sequence either up or down regardless 
of suit on the waste pile.    For example, if the top of the waste pile is a 5, you can play either a 6 or a 
4 on it.    The sequences do not "wrap around."    Only a 2 can be played on an ace, and nothing can 
be played on a king.

Whenever there are no possible plays, turn over a card in the stock by clicking on it.    This card goes
to the waste pile.

The game is won if the tableau is cleared.    If the tableau is not cleared, the object is to leave as few 
cards as possible.

New Game
Restart Game
Undo
Redo
Card Backs

Tips: Work out your sequences in advance.    Be careful to save queens for kings, and twos for aces.



Fourteen Out
Fourteen Out is a simple game to play, and is fairly easy to win.    The entire deck is dealt face up into
12 piles (8 piles of 4 cards, 4 piles of 5 cards).    Only the top card of each pile is available for play.

The object of the game is to discard all the cards in pairs that total to 14.    For example, a king and 
an ace, a queen and a 2, or an 8 and a 6.    To remove a pair, pick up one card with the mouse and 
drop it on the other.

The game is won if the entire deck is discarded.

New Game
Restart Game
Undo
Redo



Yukon
Yukon is a relative of Klondike, the Windows Solitaire game.    28 cards are dealt into 7 piles, the 
same as Klondike.    Then the remaining 24 cards are dealt face up in the rightmost 6 piles, 4 in each 
pile.

The 4 blank spots with the X's are the foundation piles.    The foundation piles are built up in suit from
ace to king.    The game is won if all 52 cards are moved to the foundation piles.

The tableaus are built down by opposite colors.    For example, a red 6 can be dropped on a black 7 
(no cards can be built on an ace).    Any face up card in the tableau may be built upon another, no 
matter how deep it is in a pile.    All cards covering it are moved together.    When a face down card is 
uncovered, it is automatically turned face up and is available for play.    Spaces created by moving an
entire pile can be filled only with kings.

New Game
Restart Game
Undo
Redo
Card Backs
Auto Play

Tips: Uncover the face down cards as soon as possible.    Don't let one foundation get too far ahead 
of the others.



Busy Aces
Busy Aces uses two decks of cards.    It is easy to play and fairly easy to win.
The eight foundations are across the top of the screen (with the X's).    To win the game, build the 8 
foundations up in suit from Ace to King.

Below the foundations on the right are 12 tableau piles.    On the left (face down) is the deck and 
below that is the discard pile.    To play, turn over cards from the deck one by one to the discard pile 
by clicking on the face-down deck.    The top card of the discard pile is always available for play.    
The top card may be moved from the discard pile to a tableau pile by dragging.    The tableau piles 
are built down by suit.    For example, a six of diamonds can go on top of a seven of diamonds.    
Cards can be played from one tableau pile to another, if possible.    Play aces immediately to the 
foundations, as well as any other cards that are possible.    There is no reason to not play cards to 
the foundation.

When all 8 foundations are filled, the game is won.

Note: The AutoPlay feature will automatically play cards to the foundation, if possible.    This is a big 
time saving feature in this game.    However, you should be aware that there are situations where 
there are two possibililities for play on the foundations, since there are two decks.    There may be 
two eights of Spades, for example, that could be played on a certain foundation.    The AutoPlay 
function may not move the same eight to this spot that you might.

New Game
ReStart Game
Undo
Redo
Card Backs
AutoPlay



5 Piles
5 Piles is an easy game to play, but fairly difficult to win.    The deck is on the upper right of the 
screen.    At the beginning of the game, 5 cards are dealt, forming the 5 piles.    Any pair of cards out 
of these 5 whose values add to 13 can be discarded.    For example, a 10 and a 3 form a pair.    To 
discard them, drag one of the cards onto the other.    Kings are discarded singly.    To discards Kings, 
simply click on them.    When all possible pairs are discarded, deal another set of 5 cards onto the 
piles by clicking on the deck.    The last 2 cards in the deck form their own piles and can be discarded
with cards from any of the 5 piles.

The game is won if all 52 cards are discarded.      The game will inform you if you win, or if you have 
no more possible moves.

New Game
ReStart Game
Undo
Redo
Card Backs



EastHaven
EastHaven is another variation on Klondike (as is Yukon).    

There are 4 foundations at the top of the screen.    To win, build the foundations up in suit from Ace to
King.    There are 7 tableau piles and 1 deck pile.    At the beginning of the game, 3 cards are dealt 
face down in each pile.    Then 1 card is dealt face up on each pile.    The tableaus are built down in 
alternating colors (as in Yukon).    For example, a black 5 can be played on a red 6.    Groups of cards
in the tableau may be moved, as long as they form an descending sequence of alternating colors 
(different from Yukon).    When the KingOnly option in the OPTIONS menu is set, an empty space 
can only be filled by a king or a legal group of cards with a king at the bottom.    When KingOnly is not
set, an empty space can be filled by any legal group of cards.    Whenever there are no more 
possible plays on the tableau, another group of 7 cards is dealt to the tableau by clicking on the deck
above the tableaus.    One card from the deck is then placed face up on each tableau pile (note that 
this may block out the previous cards).    The last 3 cards of the deck are dealt to the first 3 tableau 
piles.

The difficult part of this game is that the new cards dealt can completely ruin the tableau.    Good 
luck.    Not checking the KingOnly option makes the game somewhat easier to win.

New Game
ReStart Game
Undo
Redo
Card Backs
King Only
AutoPlay



La Belle Lucie
(including Shamrocks)
The La Belle Lucie program is actually two games in one.    One game is La Belle Lucie itself, and the
other is called Shamrocks.    To change from one game to another, select which game you want from 
Rules option in the OPTIONS menu.    Changing the rules will begin a new game.    The rules for 
each game are very similar.

La Belle Lucie is a challenging game.    The entire deck is dealt face up into 17 groups (called fans) 
of 3 cards, with 1 card left over.    There are 4 foundation piles at the top of the screen.    To win, build 
the foundations up in suit from Ace to King.

Only the top card of each fan is available for play.    One card at a time can be moved from a fan to a 
foundation, or to another fan.    The fans are built down in suit.    For example, a 8 of spades can be 
played on a 9 of spades.    Spaces made by playing all the cards of a fan are not filled.

There are two redeals.    After all possible plays have been made, redeal by clicking on the O in the 
upper left corner.    All the cards in the fans are reshuffled.    The foundations remain.    When the O 
becomes an X, there are no more redeals.
You cannot undo a redeal.

This game is tough.    Once you move a card onto a fan, the cards below are blocked until a redeal, 
unless they can be played to a foundation.    Kings block all cards below them as well.    Play cards to 
the foundation when they are available.

Shamrocks is easier to win.    In Shamrocks, the deck is dealt exactly as in La Belle Lucie.    The 
objective of building the foundations up from Ace to King is the same.

The play in the fans is different.    In Shamrocks, the fans or built either up OR down by sequence, 
regardless of suit.    For example, any 4 could be played on a 5, and so could any 6.    However, there
is a limitation of 3 cards in any one fan at any one time.    Like La Belle Lucie, empty fans cannot be 
filled.    Unlike La Belle Lucie, there are no redeals.

The maximum of 3 cards in a fan means that at the beginning of the game, if no ace can be played to
a foundation, and no card can be played on top of the single card, the position is blocked.      Also, in 
Shamrocks the foundations should be kept as even as possible; don't play cards to the foundation 
until necessary.

New Game
ReStart Game
Undo
Redo
AutoPlay



St. Helena
St. Helena uses two decks.    First, one Ace and one King from each suit are removed from the deck 
and placed in the middle of the screen.    These form the beginnings of 8 foundations, 4 "King-
foundations" and 4 "Ace-foundations".      The remaining 96 cards are dealt into 12 tableau piles 
circling the foundations.    Four piles are placed above the King-foundations, 4 piles below the Ace-
foundations, and 2 on each side of the foundations.

The objective is to build the King-foundations down in suit to aces, and the Ace-foundations up in suit
to Kings.    When all the cards are in the foundations, the game is won.

The top card of each tableau pile is always available for play on the foundations, with one exception: 
until the first redeal, cards from the piles above the King-foundations can only be played to the King-
foundations, and cards from the piles below the Ace-foundations can only be played to the Ace-
foundations.    Cards from the sides can be played anywhere, and after the first redeal, cards from 
any tableau pile can be played to any foundation.

The tableaus are built up or down in sequence, regardless of suit.    The top card of any tableau can 
be so moved to any other tableau.    For example, a 9 can be played on an 8, as can a 7.    However, 
only a Queen can be played on a King, and only a 2 can be played on an Ace.    An empty tableau 
pile cannot be filled. 

Two redeals are allowed.    In a redeal the cards are not shuffled.    Rather, each tableau pile is picked
up in counter-clockwise order, and then the cards are dealt back to each pile clockwise.    You cannot 
undo a redeal.

New Game
ReStart Game
Undo
Redo



Spiderette
Spiderette is a cross between the popular games Klondike and Spider.    There are no foundations.    
All building is done on the 7 tableau piles.    In regular Spiderette, 28 cards are dealt to the tableau as
in Klondike.    The tableaus are built down in sequence, regardless of suit.    However, building down 
by suit is preferable.    The top card of each pile is always available for play on another pile, and 
multiple cards at the top of a pile that are of the same suit and down in sequence may also be moved
as a unit.    

A space created by moving an entire pile may be filled by any card or any legal group of cards.    
Whenever there are no more possible plays, a row of 7 cards can be dealt to the tableaus by clicking
on the face down card above the tableaus.    All empty piles must be filled before the deal.    

The object of the game is to get all 13 cards of each suit in sequence in a pile.    Whenever the 13 
cards of suit are assembled in sequence, the program will automatically remove them from play.    
You win by getting all 52 cards removed.

Will o' the Wisp and Baby Spiderette
Since pure Spiderette is fairly difficult to win, the program offers 2 other rules options that are easier 
to win.    To change the rules, select "Rules" from the Options menu.

Will o' the Wisp is a variation of Spiderette with exactly the same rules, except that 21 cards are dealt
to the tableau at the beginning of the game instead of 28.    (The cards are dealt in the same fashion 
as EastHaven).    With fewer face down cards to clear, the game becomes slightly easier.

Baby Spiderette is considerably easier than regular Spiderette.    In Baby Spiderette, the tableau is 
the same as regular Spiderette, as are all the rules except one.    In Baby Spiderette, you are allowed
to move a group of cards as a block if they are in sequence regardless of suit.    In Spiderette, they 
must all be of the same suit.    This makes it easier to move cards around, and easier to win the 
game.

Undo
Redo
CardBacks



Eagle Wing
Some number of cards (13, 15, 17, 19 or 21, depending on the setting in the Options menu) are dealt
face down into what is called the trunk (in the box in the center of the screen).    The top card of the 
trunk is turned face up.    Then 8 cards are dealt face up into what are called the "wings".    Finally, 
one card is dealt face up on the foundation (in the box at the top of the screen).    

All cards of the same rank as the first foundation card are played to the other spaces in the 
foundation as soon as they become available.    The foundations are built up in suit until they contain 
13 cards, aces wrapping around on top of kings.    To play card on the foundation, pick it up and drop 
it on the foundation with the mouse.

Any top card in the wings can be played to the foundation.    Cards can be placed on other cards in 
the wings if they are of the same suit and one lower in rank.    (For example, a 3 or hearts can be 
played on a 4 of hearts).    Kings wrap around on top of aces.    There is a limit of 3 cards in each 
wing.    To play a card on the wings, pick it up a drop it on the desired wing with the mouse.    Cards 
can be moved from one wing to another, if this is possible by the rules about suits and ranks, and if 
the 3 card limit is not exceeded.    Any open spaces in the wings are automatically filled from the 
trunk until the trunk is empty.    Then open spaces can be filled from the stock, wastepile, or other 
wings.

The remainder of the deck is placed in the stock at the bottom left of the screen. Click on the stock to
move the top card to the wastepile.    The top card of the wastepile    is always available for play on 
the wings or foundation.

When the stock is empty, the wastepile can be redealt by clicking on the empty stock, assuming that 
a redeal is allowed.    The number of redeals is in the Options menu (none, 1, or 2).    

The game is won if all 52 cards are placed on the foundation.

Eagle Wing can be very easy or very difficult depending on the settings.    A 13 card trunk with 2 
redeals is fairly easy to win.    A 21 card trunk with no redeals is very difficult to win.    A happy 
medium, with a 17 card deck and 1 or 2 redeals, is generally the best to play.

Undo
Redo
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Deuces
Deuces is played with two decks.    It is very similar to Busy Aces.

At the beginning of the game, the eight 2's (the Deuces) are removed from the deck and placed in 
the middle of the screen, inside the box.    These are the 8 foundation piles.    They are to be built up 
in suit, with Aces as the highest card, above the Kings.    Ten cards are dealt around the foundation 
box.    These are the 10 tableau piles.    The tableaus are built down in suit (for example, a 4 of 
diamonds is played on a 5 of diamonds).    The remaining cards in the deck are dealt to the stock, 
and the first card in the stock is turned over to form the waste pile.    The top of the waste pile is 
always available for play on the tableau or foundations.    The top card of each tableau pile is always 
available for play on another tableau pile or the foundations.

Cards are turned up from the stock to the wastepile one at a time by clicking on the stock.    The 
game is won if all 104 cards can be played to the foundations.

Deuces is slightly harder to win than Busy Aces.    Although in the beginning the first card in each 
foundation is already played for you (unlike Busy Aces, where you must wait for all the aces to come 
out), because there are only 10 tableau piles rather than the 12 of Busy Aces, it is harder to win.

Undo
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Perpetual Motion
Perpetual Motion is a very simple game.    In fact, there is no strategy to it at all.    But totally mindless
games have their uses.

In Perpetual Motion, the entire deck is placed in the stock pile (at the far right of the screen).    Four 
cards are dealt to form 4 tableau piles.    If any cards in the tableau have the same rank (such as, two
of the cards are Jacks), the rightmost of the pair is moved on top of the leftmost (pick up the right 
card with the mouse and drop it on the left).    Once all possible pairs have been doubled up in this 
way, deal another row of 4 cards on top of the tableau by clicking on the face-down stock pile.    

After all 52 cards in the deck have been dealt out and moved (if possible), click on the ReDeal 
button.    This starts a complicated process that puts all the cards once again back in the stock.    
(note that the cards are not reshuffled, just picked up in a certain way).    

Any time an entire row of 4 cards are of the same rank (4 Jacks, for example), click on one of the 4 
cards.    The 4 cards are then removed from play.    The object of the game is to get the entire deck 
removed from play.



Storehouse
Storehouse is a variation of the popular game Canfield.    

The 4 twos in the deck around removed and put in a row.    These are the 4 foundation piles.    13 
cards are dealt in a pile below the foundations, called the storehouse. A row of 4 cards are dealt 
below the foundations.    These are the 4 tableau piles.    The remainder of the deck is dealt face 
down to the stock, with the top card of the stock turned over for the waste pile.

The foundation piles are built up by suit, wrapping around Ace on top of King.      The tableau piles 
are built down by suit.    Spaces created in the tableau are immediately filled by the top card of the 
storehouse.    The top cards of the storehouse, tableaus, and wastepile are always available for play 
on the tableaus or foundations.

Turn over cards in the stock one at a time by clicking on the stock.    There is no redeal.
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